Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Request #13015 Add https discovery for channel.xml
Submitted: 2008-01-31 04:31 UTC Modified: 2009-02-09 16:37 UTC
From: kulminaator Assigned: dufuz
Status: Closed Package: PEAR (version 1.6.2)
PHP Version: 5.2.4 OS: Linux
Roadmaps: 1.8.0alpha1, 1.7.2    
Subscription  


 [2008-01-31 04:31 UTC] kulminaator (Martin Roos)
Description: ------------ By default pear always assumes that the channel.xml is available over "just http", which is not the case for everyone. Over here we developed a little patch-set for 1.6.2 to make it work properly with https requests and look for https servers as a fallback from just http servers. The patch is not perfect, and i do believe that it should be modified, but can it's final "effect" be implemented for 1.7.x versions ? Patch provided here can be applied with : cd $YOUR_PEAR_DIR cat /tmp/Pear162PatchHttps_1.txt | patch -p1 -- Yes i have seen previous posts similar to this, but people, whatever you do currently in your PEAR code, just doesn't seem to work on it's own. Test script: --------------- pear channel-discovery your.https.server.here Expected result: ---------------- That your https://foo.bar/channel.xml is found and used Actual result: -------------- PEAR only tries http:// and ignores everything else. Even if the channel is "manually added" with ssl option set and the correct port, it still tries to use http host for channel xml prior to downloading.

Comments

 [2008-01-31 09:34 UTC] cellog (Greg Beaver)
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR.
 [2008-02-01 08:42 UTC] kulminaator (Martin Roos)
even by just briefly taking a look of Downloader.php in 1.7.0 , the bug is still there. but ok, i will try to find time to reproduce it again.
 [2008-02-01 12:42 UTC] cellog (Greg Beaver)
what is needed is switch to channel-discover to search https. channel-add https://.../channel.xml would work.
 [2008-02-04 02:10 UTC] kulminaator (Martin Roos)
Just doing "channel-add https://.../channel.xml" will not solve the issues. That is why i wrote the patch. Issues that PEAR (version 1.7.1) has: 1) PEAR/Downloader.php , line 1610 : * $host variable is prepended with ssl:// * this $host is sent as HTTP header "Host" field * apache (and any other sane web server) does not understand " Host: ssl://foobar " 2) * if issue 1 is fixed to use the real virtual host name in host field * the channel gets added, but the download/install calls still use http:// scheme, no matter what, because it's hardcoded into PEAR/Command/Channels.php doUpdate() function I'm just trying to help you guys here, not to work against you :)
 [2009-01-30 18:32 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Moved to the 1.8 schedule
 [2009-02-09 16:37 UTC] dufuz (Helgi Þormar Þorbjörnsson)
-Status: Assigned +Status: Closed
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2009-02-09 16:37 UTC] dufuz (Helgi Þormar Þorbjörnsson)
Can you please try this out ?