Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #12699 makedocs.sh script needs a better install location
Submitted: 2007-12-15 02:58 UTC Modified: 2007-12-18 21:26 UTC
From: jakubmoc Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.4.1)
PHP Version: Irrelevant OS: Gentoo Linux
Roadmaps: 1.4.2    
Subscription  


 [2007-12-15 02:58 UTC] jakubmoc (Jakub Moc)
Description: ------------ Hi, how about /usr/libexec/PhpDocumentor, or /usr/share/PhpDocumentor or whatnot? Creating subdirs in /usr/bin is really ugly. Thanks.

Comments

 [2007-12-15 21:27 UTC] ashnazg (Chuck Burgess)
makedoc.sh is not a script for general execution of PhpDocumentor. It is a utility script designed for you to _copy_ it into your own code project, customize the settings in it for said project, and run it specifically for documenting said project. It shouldn't actually be getting "installed" anywhere aside from being included in the PhpDocumentor installation's "scripts" subdirectory. Anyway, the PEAR installer would not be arbitrarily choosing /usr/bin, if that's where you're seeing it. I have to guess that was a choice by whoever packaged PhpDocumentor and/or PEAR for the distribution that you're seeing this behavior in... ?
 [2007-12-16 03:33 UTC] jakubmoc (Jakub Moc)
Meh, it was me who packaged this for Gentoo, and I certainly didn't change the location in package.xml you distribute. :) And yes, I understand it's not designed as a script for general usage, hence the suggestion in this bug (the subdir part left aside). <file baseinstalldir="/" md5sum="d7d59371f6527764cd6aa25f6f592e5e" name="scripts/makedoc.sh" role="script" /> translates into /usr/bin/scripts/makedoc.sh on install.
 [2007-12-16 13:22 UTC] ashnazg (Chuck Burgess)
Ah, that info from your perspective helps. That looks like your PEAR's config setting of "php_dir" is /usr/bin, and so _anything_ that PEAR installs will be put in /usr/bin. I would think it normal for the "bin_dir" setting to be /usr/bin, but not for "php_dir" to be that... in all the *nix installs I've done, "php_dir" is set to /usr/share/pear or /usr/share/php/pear. What values is your emerge script using for PEAR's php_dir and bin_dir ?
 [2007-12-16 13:28 UTC] jakubmoc (Jakub Moc)
php_dir is /usr/share/php on Gentoo, bin_dir is (obviously ;)) /usr/bin; and no, not everything installed goes to /usr/bin, in fact it's *only* the stuff with role="script". I'd say it's by design, but that role is not suitable for helper scripts like this which are not intended to be invoked directly.
 [2007-12-16 13:48 UTC] ashnazg (Chuck Burgess)
/me slaps forehead I finally get it... I now see how that one file is being treated differently that the other files in /scripts, and how it is ending up in bin_dir. Let me find out why this one file was specifically chosen to be placed in that location, because at first glance, I'm with you... I don't think it belongs there.
 [2007-12-18 21:26 UTC] ashnazg (Chuck Burgess)
Patched this to install makedoc.sh alongside the other /scripts items. Committed to CVS.