Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #12121 phpdoc.bat cannot launch php.exe
Submitted: 2007-09-26 05:57 UTC Modified: 2007-12-08 20:41 UTC
From: kalvaro Assigned: ashnazg
Status: Closed Package: PhpDocumentor (version 1.4.0)
PHP Version: 5.2.4 OS: Windows XP Professional
Roadmaps: 1.4.1    
Subscription  


 [2007-09-26 05:57 UTC] kalvaro (Alvaro G. Vicario)
Description: ------------ When you run phpdoc from command line you get this error message: """C:\Archivos" not recognized as an internal or external command The reason seems to be that the phpCli variable is set using quotes and when launching php.exe quotes are added again. If you replace: SET phpCli="C:\Archivos de programa\PHP\.\php.exe" with: SET phpCli=C:\Archivos de programa\PHP\.\php.exe everything works fine. Test script: --------------- phpdoc -h Expected result: ---------------- -f --filename name of file(s) to parse ',' file1,file2. Can contain complete path and * ? wildcards [...] Actual result: -------------- """C:\Archivos" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable.

Comments

 [2007-12-08 20:23 UTC] ashnazg (Chuck Burgess)
Verified I can reproduce this, on Windows XP. It looks like phpdoc.bat (used by unzip-and-go) doesn't have this issue... only pear-phpdoc.bat (used by PEAR installer) does.
 [2007-12-08 20:24 UTC] ashnazg (Chuck Burgess)
Removing the quotes around only the SET command does indeed solve the issue. Usages of the %phpCli% variable elsewhere in the script are themselves enclosed in quotes, so the quoting that is necessary for paths containing whitespaces is solved by those. This tests good for me on Windows XP.
 [2007-12-08 20:41 UTC] ashnazg (Chuck Burgess)
Committed to CVS.