Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #1876 code generates warnings with E_ALL
Submitted: 2004-07-14 19:00 UTC
From: jsnell at networkninja dot com Assigned: mw21st
Status: Bogus Package: DB_DataObject_FormBuilder
PHP Version: 4.3.3 OS: Linux
Roadmaps: (Not assigned)    
Subscription  
Comments Add Comment Add patch


Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know! Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem : 40 + 10 = ?

 
 [2004-07-14 19:00 UTC] jsnell at networkninja dot com
Description: ------------ FormBuilder won't work with all error_level settings. I will likely fix this and submit a patch. Reproduce code: --------------- set error level to E_ALL, then enter an example in Expected result: ---------------- No warnings under E_ALL Actual result: -------------- Notice: Undefined property: preDefOrder in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 411 Notice: Undefined property: preDefGroups in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 274 Notice: Undefined variable: element in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 345 Notice: Undefined property: dateFields in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 289 Notice: Undefined property: dateFields in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 289 Notice: Undefined variable: groups in /usr/local/lib/php/DB/DataObject/FormBuilder.php on line 375

Comments

 [2004-07-14 19:05 UTC] mw21st
Can you please tell us which version of FormBuilder you're referring to? Are you using a package or a CVS checkout? I always develop with E_ALL, but I haven't seen something like this in ages.
 [2004-07-14 20:44 UTC] justinpatrin
The newest CVS version doesn't even start its functions until line 473 and the comments on top have been around for a while. This looks like an *old* version of FormBuilder. Please try the newest CVS version or wait for the next release.
 [2004-07-14 23:01 UTC] jsnell at networkninja dot com
It seems that "pear install DB_DataObject_FormBuilder" (done on Monday) gave me an older version, although I have no way to verify it. Using pear to upgrade fixed the problem. Sorry to bother you, but thank you for this excellent class. I'm working on something similar to use DB_DataObject with Pager (looks like I'll probably end up writing my own paging code).
 [2004-07-14 23:15 UTC] justinpatrin
No problem, thanks for using it. Make sure that you pay attention with the next release as it will break your old code, guaranteed. There will be an included fix script which will take care of the changes you need to make, though. :-) If you're interested, you can get the newest version form CVS and try it out for us. We'd much appreciate further testing.