Vote Details for "File_CSV_Get" by izi

» Details
  • Voter: David Jean Louis 
  • Vote: +1 (conditional)
  • Reviews: Cursory source review, Deep source review
» Comment
I agree with all the remarks concerning method naming, and this also apply to File_CSV_GetSql.
BTW I'm not sure this class is a good idea, it's beyond the scope of the package imho (and it seems to be vulnerable to sql injections).

Please also remove doc/phpdoc and misc/*.output from your package.xml, these files should not be installed (and README and LICENCE should have "doc" role instead of "data").

I'm glad you listened to all remarks and made the relevant changes, the code looks much better now.