Comments for "BinaryUtils"

» Submit Your Comment
Comments are only accepted during the "Proposal" phase. This proposal is currently in the "Finished" phase.
» Comments
  • Martin Jansen  [2004-08-24 11:46 UTC]

    The code looks like fine stuff, even though it is lacking a bit more documentation.

    Do you see any chance to make the package PHP 4 compatible? On a first glance I couldn't spot any place that strictly requires PHP 5.
  • Markus Nix  [2004-08-24 12:37 UTC]

    Hi Martin,

    there is absolutely no need to force PHP 5 with this code. I switched back to PHP 4. Take a look at the CVS


  • Alan Knowles  [2004-08-24 13:27 UTC]

    It looks like it should be Maths_Binary
  • Alan Knowles  [2004-08-24 13:27 UTC]

    Opps, sorry make that Math_Binary
  • Jesus M. Castagnetto  [2004-08-24 23:13 UTC]

    Agree with Alan. A better name could be Math_ Binary (although that is a bit more general), or perhaps Math_BinaryOps (for Operations), or even Math_BinaryUtils. The last one is not as specific as the second one.

    I know that using a more specific name will make the static method calls a tad longer, but it will make things clear which is always a good thing.
  • Markus Nix  [2004-08-25 06:53 UTC]

    Hmm, not sure about the naming. You'll find an add and an subtract method, but that doesn't make it a Math package. I would like to see it it a more general place like Tools.


  • Martin Jansen  [2004-08-25 10:46 UTC]

    Math_BinaryUtils sounds like the best name.