PEAR_PackageUpdate::setMinimumState – Sets the user's preference for asking about release states.


require_once 'PEAR/PackageUpdate.php';

boolean PEAR_PackageUpdate::setMinimumState ( string $minState )


Sets the user's preference for asking about minimum release state.


throws PEAR_PACKAGEUPDATE_ERROR_INVALIDSTATE, when invalid state of release is used (snapshot|devel|alpha|beta|stable).


since 0.4.0a1

This function can not be called statically.

Return value

boolean - TRUE if the preference was set properly, FALSE otherwise.

PEAR_PackageUpdate::setMinimumReleaseType (Previous) PEAR_PackageUpdate::setPreference (Next)
Last updated: Tue, 02 Jun 2009 — Download Documentation
Do you think that something on this page is wrong? Please file a bug report or add a note.
View this page in:

User Notes:

There are no user contributed notes for this page.