PEAR_PackageUpdate::setMinimumState

PEAR_PackageUpdate::setMinimumState – 更新を問い合わせる状態についてのユーザ設定を指定する

Synopsis

require_once 'PEAR/PackageUpdate.php';

boolean PEAR_PackageUpdate::setMinimumState ( string $minState )

Description

更新を問い合わせる最低のリリース状態についてのユーザ設定を指定します。

Throws

正しいリリース状態 (snapshot|devel|alpha|beta|stable) 以外を指定した場合に PEAR_PACKAGEUPDATE_ERROR_INVALIDSTATE をスローします。

Note

since 0.4.0a1

This function can not be called statically.

Return value

boolean - 正しく設定できた場合に TRUE、それ以外の場合に FALSE を返します。

更新を問い合わせる最低のリリース型についてのユーザ設定を指定する (Previous) 指定した設定項目に値を設定する (Next)
Last updated: Fri, 22 Aug 2014 — Download Documentation
Do you think that something on this page is wrong? Please file a bug report or add a note.
View this page in:

User Notes:

There are no user contributed notes for this page.