PEAR_PackageUpdate::setMinimumReleaseType

PEAR_PackageUpdate::setMinimumReleaseType – 更新を問い合わせる最低のリリース型についてのユーザ設定を指定する

Synopsis

require_once 'PEAR/PackageUpdate.php';

boolean PEAR_PackageUpdate::setMinimumReleaseType ( string $minType )

Description

更新を問い合わせる最低のリリース型についてのユーザ設定を指定します。

Throws

正しい型 (bug|minor|major) 以外を指定した場合に PEAR_PACKAGEUPDATE_ERROR_INVALIDTYPE をスローします。

Note

since 0.4.0a1

This function can not be called statically.

Return value

boolean - 正しく設定できた場合に TRUE、それ以外の場合に FALSE を返します。

利用者による、このパッケージに対する "Don't Ask Again Until Next Release" を設定する (Previous) 更新を問い合わせる状態についてのユーザ設定を指定する (Next)
Last updated: Fri, 29 Aug 2014 — Download Documentation
Do you think that something on this page is wrong? Please file a bug report or add a note.
View this page in:

User Notes:

There are no user contributed notes for this page.