PEAR_PackageUpdate::setMinimumState

PEAR_PackageUpdate::setMinimumState – Sets the user's preference for asking about release states.

Synopsis

require_once 'PEAR/PackageUpdate.php';

boolean PEAR_PackageUpdate::setMinimumState ( string $minState )

Description

Sets the user's preference for asking about minimum release state.

Throws

throws PEAR_PACKAGEUPDATE_ERROR_INVALIDSTATE, when invalid state of release is used (snapshot|devel|alpha|beta|stable).

Note

since 0.4.0a1

This function can not be called statically.

Return value

boolean - TRUE if the preference was set properly, FALSE otherwise.

Sets the user's preference for asking about release types. (Previous) Sets the given preference to the given value. (Next)
Last updated: Tue, 16 Sep 2014 — Download Documentation
Do you think that something on this page is wrong? Please file a bug report or add a note.
View this page in:

User Notes:

There are no user contributed notes for this page.