PEAR2 Coding Standards

Table of Contents

Coding Standards to be used in PEAR2 (version 1)

2007-12-24

This document cannot be considered complete (e.g.: the future of namespaces is uncertain).

  • This document describes the coding standards and coding conventions for the new PEAR2 repository.
  • These coding standards will expire on March 1, 2008, and must be reviewed and renewed by the PEAR Group in order to continue
  • Packages that wish to be accepted into the PEAR2 repository must conform to these standards
  • The minimum PHP version supported will be the earliest version that supports namespaces, most likely PHP version 5.3.0. This RFC will be updated as soon as the exact version is known.
  • package.xml 2.0 or newer is required for all packages
The PEAR toolbox (Previous) Introduction (Next)
Last updated: Sun, 21 Dec 2014 — Download Documentation
Do you think that something on this page is wrong? Please file a bug report or add a note.
View this page in:

User Notes:

There are no user contributed notes for this page.