Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #9841 incorrect dependency information shown on uninstall
Submitted: 2007-01-15 08:27 UTC Modified: 2007-02-10 23:35 UTC
From: wiesemann Assigned: cellog
Status: Closed Package: PEAR (version 1.5.0)
PHP Version: 5.2.0 OS: Irrelevant
Roadmaps: 1.5.1    
Subscription  


 [2007-01-15 08:27 UTC] wiesemann (Mark Wiesemann)
Description: ------------ As already described via email: pear uninstall Structures_DataGrid-beta#renderers gives this message: pear/Structures_DataGrid_Renderer_CSV (version >= 0.1.0) can be optionally used by installed package "pear/structures_datagrid" uninstall ok: channel://pear.php.net/Structures_DataGrid_Renderer_CSV-0.1.3 This shown only for this renderer, and not for any DataSource driver. This message is useless and should be removed.

Comments

 [2007-01-15 15:58 UTC] cellog (Greg Beaver)
I wouldn't call this useless. It is just wrong, as Structures_DataGrid is actually being uninstalled too, and so there should be no warning.
 [2007-01-15 16:28 UTC] wiesemann (Mark Wiesemann)
> I wouldn't call this useless. It is just wrong, as > Structures_DataGrid is actually being uninstalled too, > and so there should be no warning. Okay, true. But then it should be shown for all packages, not only for the CSV renderer in this case. I've slightly changed the summary.
 [2007-01-15 16:31 UTC] cellog (Greg Beaver)
not to be pedantic, but here is the situation: say isntalled package X can optionally use installe package Y. If you run: pear uninstall Y it should warn that X optionally uses Y, and it does if you run pear uninstall X Y There is no error - you're uninstalling both, and no warning should be shown. Hence, the dependency information is incorrect, not just incomplete
 [2007-01-15 16:36 UTC] wiesemann (Mark Wiesemann)
Thanks for the analysis. I only thought on the reported case of SDG uninstallation. The summary then makes sense again.
 [2007-01-21 19:18 UTC] cellog (Greg Beaver)
I'm going to postpone this to 1.5.1 so we can get 1.5.0 out. Since it doesn't seem to adversely affect current functionality, it should be safe to do so.
 [2007-02-10 23:35 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.