Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.8.9

Bug #9725 multipart/related & alternative wrong order
Submitted: 2007-01-03 11:41 UTC Modified: 2009-12-30 11:53 UTC
From: c dot meisinger at livingliquid dot com Assigned: cipri
Status: Closed Package: Mail_Mime (version 1.3.1)
PHP Version: 5.0.5 OS: Linux SuSE 10.0
Roadmaps: 1.6.0RC1, 1.4.0, 1.4.0a2    
Subscription  


 [2007-01-03 11:41 UTC] c dot meisinger at livingliquid dot com (Christian Meisinger)
Description: ------------ Starting-point: text body html body with inline images (addHTMLImage) The problem is that multipart/alternative does not work correctly. When i view the email in html mode, everything is ok. When i switch to plain text mode the html part is used NOT the text part. Layout of email is: --alternative text/plain --alternative --related text/html --related gif --related gif --related-- --alternative-- Looks good to me but it seems so it doesn't work. I copy&pasted the email source code, changed the relate/alternative order and used mail() to send it. Working layout: --related --alternative text/plain --alternative text/html --alternative-- --related gif --related gif --related-- And this layout works. I've tested this with Thunderbird 1.5.0.9 and Outlook Express 7 (IE7).

Comments

 [2007-03-08 12:23 UTC] cipri (Cipriano Groenendal)
Thank you for taking the time to report a problem with the package. Unfortunately you are not using a current version of the package -- the problem might already be fixed. Please download a new version from http://pear.php.net/packages.php If you are able to reproduce the bug with one of the latest versions, please change the package version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PEAR. Please try the new Mail_Mime 1.4.0a1 package as it contains a lot of fixes.
 [2007-03-26 10:17 UTC] roballoway (Rob Alloway)
I am having the same problem with 1.4.0a1
 [2007-04-03 12:32 UTC] cipri (Cipriano Groenendal)
Currently testing a fix in my local cvs version. Does this problem occure with any other combinations? Such as emails with attachments and inline images? If so, please let me know the order these should go in and I'll fix those right away aswell.
 [2007-04-04 05:04 UTC] c dot meisinger at livingliquid dot com
mh right now this seems to be the only combination which couses troubles. only text/html/inline images, regardless how many images or what image type.
 [2007-04-05 03:35 UTC] cipri (Cipriano Groenendal)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2007-05-05 10:07 UTC] cipri (Cipriano Groenendal)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Mail_Mime Fixed in 1.4.0
 [2009-12-18 15:09 UTC] alec (Aleksander Machniak)
-Status: Closed +Status: Open
Actually, what client has problem with this? Conficts with #13444. I'd like to revert this hack.
 [2009-12-30 11:53 UTC] alec (Aleksander Machniak)
-Status: Assigned +Status: Closed -Roadmap Versions: 1.4.0a2, 1.4.0 +Roadmap Versions: 1.4.0a2, 1.4.0, 1.6.0RC1
Reverted fix for this bug as non-RFC complaint. See bug #13444.