Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.5

Bug #9676 Problem ready Mac Archive Files
Submitted: 2006-12-21 20:01 UTC Modified: 2008-05-28 10:55 UTC
From: andrew dot eddie at ivivio dot com Assigned: cbrunet
Status: Closed Package: File_Archive (version 1.5.3)
PHP Version: 5.1.4 OS: Windows
Roadmaps: (Not assigned)    
Subscription  


 [2006-12-21 20:01 UTC] andrew dot eddie at ivivio dot com (Andrew Eddie)
Description: ------------ Files created using the Mac Archive facility (in Finder, right-click and select "Create Archive of "yyy") are incorrected read. The zip is upacked but only the first file. If a folder is the first entry (in my case it was a .svn folder). It recursed until it found the first file. It seems like the trigger to go to the "next" file is not working correctly. Zip's are correctly read by other archive readers (windows zip browser, Z-Zip, Beyond Compare, etc). Files rezipped in windows are correctly unpacked. The issue has also been reported here: http://poocl.la-grotte.org/phorum/read.php?3,133 Thanks in advance for a resolution. Test script: --------------- $r = File_Archive::extract( File_Archive::read($archivename.'/'), File_Archive::toFiles($extractdir) );

Comments

 [2008-03-28 11:07 UTC] User who submitted this comment has not confirmed identity
If you submitted this note, check your email.If you do not have a message, click here to re-send
MANUAL CONFIRMATION IS NOT POSSIBLE.  Write a message to pear-dev@lists.php.net
to request the confirmation link.  All bugs/comments/patches associated with this

email address will be deleted within 48 hours if the account request is not confirmed!
 [2008-03-28 11:12 UTC] charlie (Charlie Curtsinger)
This is a problem with the zip reader. In the ZIP specification (http://www.pkware.com/documents/casestudies/APPNOTE.TXT) the format allows for a signature before the file descriptor section (mentioned toward the bottom of the document). I've added a patch that will skip over the data descriptor when it encounters this header signature. Previously, the reader encountered this header and crashed out reporting an invalid archive (although this error never made it to the dir appender). The data descriptor can just be ignored, since file size and compressed size are fetched from the central directory.
 [2008-05-28 10:55 UTC] cbrunet (Charles Brunet)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.