Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.4

Bug #9639 pear installer allows removing a required dependency
Submitted: 2006-12-16 12:53 UTC Modified: 2006-12-18 15:22 UTC
From: olivierg Assigned:
Status: Bogus Package: PEAR (version 1.5.0RC2)
PHP Version: 4.4.4 OS: Debian Etch
Roadmaps: (Not assigned)    
Subscription  


 [2006-12-16 12:53 UTC] olivierg (Olivier Guilyardi)
Description: ------------ I have Structures_DataGrid and all of its drivers installed. Structures_DataGrid is a required dependency for all of its drivers. I type: pear uninstall structures_datagrid And it says: uninstall ok: channel://pear.php.net/Structures_DataGrid-0.8.0 All drivers are still here, in a unusable state.

Comments

 [2006-12-16 16:46 UTC] cellog (Greg Beaver)
I cannot reproduce this bug, and don't see how it could occur without a corrupted installation of some kind (I stepped through the whole process with a debugger to be sure). Please verify that you have taken these steps: pear -V You should see 1.5.0RC2 If not, then mark this bug as bogus. Next run: pear install Structures_DataGrid pear install Structures_DataGrid_Whatever then, run pear list *verify that the packages are installed* then run pear uninstall Structures_DataGrid If you still get the same error, then let me know. Please run this test as soon as possible.
 [2006-12-18 10:09 UTC] olivierg at php dot net (Olivier Guilyardi)
I can't reproduce this bug anymore. I did exactly what you said (yes it's 1.5.0RC2) and it works, it complains about dependencies. However, IIRC, I suspect the bug appeared when I tried to uninstall the package with PEAR 1.5.0RC2, but I had installed it (and the drivers) a long time ago with a 1.4.X (older?) version. In other words: I upgraded the pear installer between installing and uninstalling.
 [2006-12-18 15:22 UTC] cellog (Greg Beaver)
aha - I know for a fact that some earlier versions of PEAR 1.4.x did in fact register dependencies incorrectly in the database, but did not know it affected some uninstalls. I am marking the bug bogus, but will be writing a message and doing a blog post about the problem, after I do some research to figure out which PEAR versions are affected. Thanks