Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.0a3

Bug #9611 Wrong OS determing!
Submitted: 2006-12-14 05:02 UTC Modified: 2007-11-24 14:50 UTC
From: admin at svetoslav dot ru Assigned: jorrit
Status: Closed Package: Net_FTP
PHP Version: 5.2.0 RC4 OS: Windows XP
Roadmaps: 1.3.3    
Subscription  


 [2006-12-14 05:02 UTC] admin at svetoslav dot ru (Svetoslav Onosov)
Description: ------------ Some FTP-servers return rawlist with (?) in user field. So, Net_FTP mistakes on determining Operating System. Test script: --------------- $server = new Net_FTP(...); ... print_r($server->ls(null, NET_FTP_RAWLIST)); print_r($server->ls(null, NET_FTP_DIRS_FILES)); Expected result: ---------------- Array ( [0] => drwxr-xr-x 75 upload (?) 3008 Oct 30 21:09 ftp1 ); Array ( [0] => Array ( [is_dir] => d [rights] => rwxr-xr-x [files_inside] => 1 [user] => upload [group] => (?) [file_size] => 3008 [date] => Oct 30 21:09 [file_name] => ftp1 [file_date] => 1162231740 ) ) Actual result: -------------- Array ( [0] => drwxr-xr-x 75 upload (?) 3008 Oct 30 21:09 ftp1 ); Array ( [0] => Array ( [file_name] => 21:09 ftp1 [date] => drwxr-xr-x 75 upload (?) 3008 [file_size] => 30 [is_dir] => [file_date] => ) )

Comments

 [2007-03-01 14:25 UTC] mwillbanks (Mike Willbanks)
Is there a way to get more information as far as what FTP server was being utilized?
 [2007-03-11 12:43 UTC] mj (Martin Jansen)
Setting status to "Feedback". Svetoslav: It is in fact really important to get the information requested by Mike, because we otherwise have no reliable way to reproduce your problem. Thanks!
 [2007-10-02 06:33 UTC] bbrunekreeft (Bert Brunekreeft)
Same problem here: print_r($server->ls(null, NET_FTP_RAWLIST)); gives: Array ( [0] => -rw-r--r-- 1 myname(?) 2124221 Sep 28 01:42 file01 [1] => -rw-r--r-- 1 myname(?) 3 Sep 28 01:42 file02 [2] => -rw-r--r-- 1 myname(?) 125076 Sep 28 12:24 file03 [3] => -rw-r--r-- 1 myname(?) 3 Sep 28 12:24 file04 ) Unfortunately, I'm unable to determine the FTP server info.
 [2007-11-21 17:46 UTC] jorrit (Jorrit Schippers)
A fix could be to allow (, ? and ) in usernames and groups. Easy fix.
 [2007-11-24 14:50 UTC] jorrit (Jorrit Schippers)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.