Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.4

Bug #9380 Auth via POP3: lost $server default value
Submitted: 2006-11-19 05:30 UTC Modified: 2006-12-16 08:36 UTC
From: francesco dot foschi at gmail dot com Assigned: aashley
Status: Closed Package: Auth (version 1.4.2)
PHP Version: Irrelevant OS: Irrelevany
Roadmaps: (Not assigned)    
Subscription  


 [2006-11-19 05:30 UTC] francesco dot foschi at gmail dot com (Francesco)
Description: ------------ Using auth via POP3, with default array options values (without any variable in constuction call), Auth_Container_POP3 lost $server value (default: localhost) Test script: --------------- require_once "Auth.php"; // A POP3 is used as storage container in this example $a = new Auth("POP3"); For resolv this, you can change line 115 in Container/POP3.php } else { with: } else if( ! is_null($server)) { Expected result: ---------------- in class Container/POP3.php, dump of $this (line 115): print_r($this): Auth_Container_POP3 Object ( [server] => localhost [port] => 110 [method] => 1 [activeUser] => ) Actual result: -------------- in class Container/POP3.php, dump of $this (line 115): print_r($this): Auth_Container_POP3 Object ( [server] => [port] => 110 [method] => 1 [activeUser] => )

Comments

 [2006-12-05 20:16 UTC] aashley at php dot net (Adam Ashley)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.