Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.1

Bug #927 two bugs with paragraphs
Submitted: 2004-02-29 10:38 UTC Modified: 2004-03-14 07:21 UTC
From: h_wendel at cojobo dot net Assigned: pmjones
Status: Closed Package: Text_Wiki
PHP Version: 4.3.4 OS: gentoo
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-29 10:38 UTC] h_wendel at cojobo dot net
Description: ------------ I found three bugs (at least i think they are bugs), this are bugs that make Text_Wiki really useless for me, otherwise it's just great, any help is welcome :) the first one: Code: ----- Text Text Text * list * list ----- Result: ----- Text Text Text <ul> <li>list</li> <li>list</li> </ul> ----- Expected Result: ----- <p>Text Text Text</p> <ul> <li>list</li> <li>list</li> </ul> ----- the second one: Code: ----- Text Text Text. Text Text Text. Text Text Text. ----- Result: ----- Text Text Text. <p>Text Text Text.</p> <p>Text Text Text.</p> ----- Expected Result: ----- <p>Text Text Text.<br/>Text Text Text.</p> <p>Text Text Text.</p> and the third one: Code: ----- Text Text Text. Text Text Text. ----- Result: ----- <p>Text Text Text.</p> Text Text Text. ----- Expected Result: ----- <p>Text Text Text.</p> <p>Text Text Text.</p>

Comments

 [2004-02-29 10:40 UTC] h_wendel at cojobo dot net
I found three bugs (at least i think they are bugs), this are bugs that make Text_Wiki really useless for me, otherwise it's just great, any help is welcome :) the first one: Code: ----- Text Text Text * list * list ----- Result: ----- Text Text Text <ul> <li>list</li> <li>list</li> </ul> ----- Expected Result: ----- <p>Text Text Text</p> <ul> <li>list</li> <li>list</li> </ul> ----- the second one: Code: ----- Text Text Text. Text Text Text. ----- Result: ----- <p>Text Text Text.</p> Text Text Text. ----- Expected Result: ----- <p>Text Text Text.</p> <p>Text Text Text.</p> ----- and the third one: Code: ----- Text Text Text. Text Text Text. Text Text Text. ----- Result: ----- Text Text Text. <p>Text Text Text.</p> <p>Text Text Text.</p> ----- Expected Result: ----- <p>Text Text Text.<br/>Text Text Text.</p> <p>Text Text Text.</p> -----
 [2004-03-01 15:53 UTC] pmjones
This report details one bug and one "behaves as expected." The "behaves as expected" relates to <br /> tags. Text_Wiki does not support single newlines (line breaks) at this time, as it interferes with semantic processing of elements (i.e., blocks need to be marked with their proper tags, such as <p> and <ul>, and not be marked up only for display, which are the primary use line breaks). The bug relates to paragraphs not being properly identified. Although this too behaves as expected, in that a paragraph is identified as a line of text followed by two newlines, the behavior is not intuitive in short pieces (i.e., one line on a page should be a paragraph). Short term fix: hit return twice after each text block you want to mark as a paragraph. Long term fix: I will modify the prefilter rule to forcibly add newlines at the top and bottom of the source text to fool the paragraph rule; this will also help with some of the other rule parses, notably the list rules.
 [2004-03-02 16:43 UTC] pmjones
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php Fixed in release 0.8.3.
 [2004-03-03 09:08 UTC] h_wendel at cojobo dot net
Thanks for your quick reply and fix :) Although I said it were two bugs in the Subject, it were three that i posted. You forgot this one (a workaround is two add two newlines between the paragraph and the list, but it works this way for tables, etc.): Code: ----- Text Text Text * list * list ----- Result: ----- Text Text Text <ul> <li>list</li> <li>list</li> </ul> ----- Expected Result: ----- <p>Text Text Text</p> <ul> <li>list</li> <li>list</li> </ul> ----- I see that the <br/> thing is not a bug, but do you have any idea how to implement it, it is very important for me. mfg, heinrich
 [2004-03-13 18:06 UTC] pmjones
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php This is fixed in release 0.10 alpha.
 [2004-03-14 05:41 UTC] h_wendel at cojobo dot net
sorry for bugging you again, but it still doesn't work :/
 [2004-03-14 07:17 UTC] pmjones
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php OK, this time it's *really* fixed (0.10.1 alpha).
 [2004-03-14 07:21 UTC] h_wendel at cojobo dot net
You rock guy :) Now i'm only waiting for the <br/> rule ;)