Report new bug | New search | Development Roadmap Status: Open | Feedback | All

Bug #9209 Missing package description in proposal editor
Submitted: 2006-11-01 14:11 UTC Modified: 2006-12-16 16:59 UTC
From: morse Assigned: cellog
Status: Closed Package: PEPr
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2006-11-01 14:11 UTC] morse (David Morse)
Description: ------------ When I try to edit proposal DB_Table_Database using the http://pear.php.net/pepr/pepr-proposal-edit.php page, the BBcode source for the current package description does not appear in the "package description" text box. I have not saved changes to anything else for fear of having to rewrite the package description.

Comments

 [2006-11-01 14:14 UTC] wiesemann (Mark Wiesemann)
This got broken by the following change in pearweb/public_html/pepr/pepr-proposal-edit.php: - 'pkg_describtion' => $proposal->pkg_describtion, + 'pkg_description' => $proposal->pkg_description, (in pearweb/include/pepr/pepr.php description is still spelled wrongly)
 [2006-11-01 17:44 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2006-11-01 17:45 UTC] arnaud (Arnaud Limbourg)
On a local version I cannot reproduce this but on production I get DB Error: null value violates not-null constraint when try to add a test proposal.
 [2006-11-01 18:10 UTC] wiesemann (Mark Wiesemann)
When trying to view a proposal, I get: Fatal error: Call to undefined function: getparseddescribtion() in /usr/local/www/pearweb/public_html/pepr/pepr-proposal-show.php on line 43
 [2006-11-01 18:20 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. (again)