Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.7

Bug #896 PEAR QA: improvement for get_class()-usage
Submitted: 2004-02-26 09:19 UTC Modified: 2004-03-01 10:55 UTC
From: pear-qa at lists dot php dot net Assigned: eru
Status: Closed Package: Services_Weather
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-26 09:19 UTC] pear-qa at lists dot php dot net
Description: ------------ ## from the PEAR QA team ## ## quality-assurance related ## Please note that if you don't react to this issue within 4 weeks the PEAR QA-team will take care of it automatically. This is not "rude" but necessary for QA. If this is a "false positive" and your package is not affected please apologize. This package uses get_class()-calls without care for case-sensitivity of the returned classnames. In PHP 4.x the default for getclass() was that lowercase classnames were returned. However, due to extended DOM functionality, PHP 5.x returns classnames with correct upper-and-lowercase. If you intend to run your package under both PHP4 and PHP5 please consider using case-independent comparisons or apply case-fixes. Found in: FILE: '/cvs/php/pear/Services_Weather/Weather.php' : /cvs/php/pear/Services_Weather/Weather.php(193): return (is_object($value) && (get_class($value) == "pear_error" || is_subclass_of($value, "pear_error"))); ---------------------------------------- FILE: '/cvs/php/pear/Services_Weather/Weather/Common.php' : /cvs/php/pear/Services_Weather/Weather/Common.php(184): if (is_object($cache) && (get_class($cache) == "cache" || is_subclass_of($cache, "cache"))) { ---------------------------------------- FILE: '/cvs/php/pear/Services_Weather/Weather/Metar.php' : /cvs/php/pear/Services_Weather/Weather/Metar.php(756): } elseif (get_class($result) != "db_result" || $result->numRows() == 0) { /cvs/php/pear/Services_Weather/Weather/Metar.php(834): } elseif (get_class($result) != "db_result" || $result->numRows() == 0) { /cvs/php/pear/Services_Weather/Weather/Metar.php(882): } elseif (get_class($result) != "db_result" || $result->numRows() == 0) { /cvs/php/pear/Services_Weather/Weather/Metar.php(981): } elseif (get_class($result) != "db_result" || $result->numRows() == 0) { Reproduce code: --------------- Affected are constructs like: if (get_class($foo) == 'foo') { ... } Possible solutions for correct class-checks: strtolower(get_class($foo)) == 'foo' is_a($foo, 'foo') !strcasecmp(get_class($foo), 'foo')

Comments

 [2004-03-01 10:55 UTC] eru at php dot net
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.