Report new bug | New search | Development Roadmap Status: Open | Feedback | All

Bug #8842 package.xml package name need not match case and must
Submitted: 2006-10-03 11:13 UTC Modified: 2006-10-31 16:22 UTC
From: alex dot brims at gmail dot com Assigned: cellog
Status: Closed Package: Web Site
PHP Version: 4_4 CVS-2006-10-03 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2006-10-03 11:13 UTC] alex dot brims at gmail dot com (Alex)
Description: ------------ MP3_ID - all releases return not found

Comments

 [2006-10-03 14:57 UTC] mj (Martin Jansen)
Confirmed; need to investigate. For now, one can use the old link format: http://pear.php.net/get/MP3_ID
 [2006-10-03 15:13 UTC] mj (Martin Jansen)
For MP3_Id this has been fixed. But the general problem persists: The package was registered as MP3_ID on pear.php.net, while its name in package.xml is MP3_Id ('D' != 'd'). In the old download infrastructure this was no problem because it works case-insensitive. The new download interface is case-sensitive. This report will remain open and assigned until I get around to properly fix it.
 [2006-10-31 16:18 UTC] cellog (Greg Beaver)
this can be fixed in release-upload.php
 [2006-10-31 16:22 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.