Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.26.0

Request #8808 RSS feed for bug system
Submitted: 2006-09-28 11:52 UTC Modified: 2007-05-06 16:25 UTC
From: wiesemann Assigned: cellog
Status: Closed Package: pearweb
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: 1.15.1    
Subscription  


 [2006-09-28 11:52 UTC] wiesemann (Mark Wiesemann)
Description: ------------ It would be a nice addition to sync the recent RSS feed additions/changes from bugs.php.net to the PEAR bug tracker. This might put too much load on the current server, so waiting with this until there is a new server might be good idea.

Comments

 [2007-04-28 07:59 UTC] till (Till Klampaeckel)
I tried the following URL/bug and there seems to be at least one problem with the RSS feeds on bugs.php.net since my reader (Mozilla Firefox) chokes and only displays the initial report and none of the comments. http://bugs.php.net/rss/bug.php?id=27372&format=rss http://feedvalidator.org/check.cgi?url=http%3A%2F%2Fbugs.php.net%2Frss%2Fbug.php%3Fid%3D27372%26format%3Drss I think a solution would be to use proper "tags" in the feed and then to "generate" HTML in <description> and <title> and wrap both into CDATA.
 [2007-05-04 15:14 UTC] cellog (Greg Beaver)
Guys - I need some help here, can you cvs upd and try to test this? Just browse to any bug on the system, and you'll see a feed that is available
 [2007-05-04 15:33 UTC] wiesemann (Mark Wiesemann)
Short test: - in bugs/bug.php it needs to be /feeds/ instead of /rss/ (line 561; at least in my httpd.conf there is only a rewrite rule for /feeds/) - Firefox 2 (Win) shows the feed here - the generated links in the feed seem to be tied to pear.php.net (didn't look into the code yet) - time is in the future (entries from today 15.00 UTC are shown as 00.00 local time in my feed reader) - all links point to he same anchor, e.g. http://pear.php.net/bugs/2#2007-05-04+22%3A24%3A34 (22:24 is local time on that I clicked on the feed) - in the final version a feed icon should be shown in the bug tracker (not every browser is able to auto-detect feeds)
 [2007-05-04 16:03 UTC] wiesemann (Mark Wiesemann)
Some more comments: - my feed reader (FeedDemon) shows the title (source: "[Assigned] Test") as "[] Test" - the title should have a reference to PEAR, e.g. "PEAR Bug #4711: Test" if the summary is "Test" and the ID is 4711 - Avant Browser (add-on for Internet Explorer) can't show the feed in its internal feed reader (seems to be the same problem that Till described for bugs.php.net's feed, I can reproduce the problem there) - unconfirmed comments (from people that are not logged-in) are shown in the feed with a funny title like "#3407f462408449bb95c" Despite this amount of comments, this new code seems to be a good start.
 [2007-05-04 16:10 UTC] wiesemann (Mark Wiesemann)
Sorry, for the spam. ;-) Last comment for today: - it would be good to also have a bug feed per package (showing all new bugs/requests and their comments)
 [2007-05-05 17:33 UTC] cellog (Greg Beaver)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/pearweb there is a bug feed per search possible. Feed per package is much more complex, open a separate feature request for that one.
 [2007-05-05 17:33 UTC] cellog (Greg Beaver)
that should be the fixed in cvs message, sorry
 [2007-05-06 04:40 UTC] wiesemann (Mark Wiesemann)
Dates are still wrong. A bug comment written on 11:28 is shown as written on 18:28 in my feed reader. In the feed it is written as: <dc:date>2007-05-06T11:28:21-05:00</dc:date> Without the "-05:00" it should be right at least here. But I'm not a timezone expert.
 [2007-05-06 05:42 UTC] till (Till Klampaeckel)
A an RSS/RDF-compatible date should be returned by <?php date('r', $foo_ts); ?> Also, on this bug, a feed is linked: http://pear.php.net/rss/bug_8808.rss It returns a 404 for me.
 [2007-05-06 09:55 UTC] wiesemann (Mark Wiesemann)
> Also, on this bug, a feed is linked: > http://pear.php.net/rss/bug_8808.rss > > It returns a 404 for me. I had reported that after Greg's first commit. It's fixed in CVS, but the file was synced to early into the website. The correct address is: http://pear.php.net/feeds/bug_8808.rss
 [2007-05-06 16:25 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.