Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.8.5

Bug #8768 Valid URL's are marked invalid
Submitted: 2006-09-22 16:37 UTC Modified: 2006-12-16 06:17 UTC
From: jeichorn Assigned: amir
Status: Closed Package: Validate (version 0.6.4)
PHP Version: Irrelevant OS:
Roadmaps: 0.8.0    
Subscription  


 [2006-09-22 16:37 UTC] jeichorn (Joshua Eichorn)
Description: ------------ Urls that work in my browser fail to validate I don't see any reason this url wouldn't be valid but its failing anyway. I've included an example script which has the setup im using The url i've been testing with is: http://www.theledger.com/apps/pbcs.dll/article?AID=/20060916/ZNYT01/609160436/1001/BUSINESS Test script: --------------- require_once 'Validate.php'; $url = "http://www.theledger.com/apps/pbcs.dll/article?AID=/20060916/ZNYT01/609160436/1001/BUSINESS"; $options = array('allowed_schemes' => array('http','https'), 'domain_check' => true); if (!Validate::uri($url,$options)) { echo 'Failed'; } else { echo 'Good'; }

Comments

 [2006-09-22 20:59 UTC] amir at php dot net (Amir Mohammad Saied)
Well, at least works for me. As you've turned on "domain_check" be sure about your DNS configs. btw. Check it out w/o domain_check and see if it fails again?
 [2006-09-23 13:55 UTC] josh at bluga dot net (Joshua Eichorn)
turning off domain_check didn't make a difference for me setting strict too '' did what areas of the check does strict apply too
 [2006-09-27 04:42 UTC] amir at php dot net (Amir Mohammad Saied)
Thank you for taking the time to write to us, but this is not a bug. The full complience to rfc2396 is not achieved by default. The characters ';/?:@$,' will not be accepted in the query part if url isn't encoded.
 [2007-10-14 13:11 UTC] User who submitted this comment has not confirmed identity
If you submitted this note, check your email.If you do not have a message, click here to re-send
MANUAL CONFIRMATION IS NOT POSSIBLE.  Write a message to pear-dev@lists.php.net
to request the confirmation link.  All bugs/comments/patches associated with this

email address will be deleted within 48 hours if the account request is not confirmed!