Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.7

Bug #8761 Getting form's "action" attribute fails in HTML_AJAX.js formSubmit
Submitted: 2006-09-21 12:25 UTC Modified: 2006-11-21 10:12 UTC
From: alex dot chumak at gmail dot com Assigned: auroraeosrose
Status: Closed Package: HTML_AJAX (version 0.5.0)
PHP Version: 5.1.6 OS: OS X + Safari
Roadmaps: 0.5.1    
Subscription  


 [2006-09-21 12:25 UTC] alex dot chumak at gmail dot com (Alex Chumak)
Description: ------------ Using the 0.5 beta HTML_AJAX had a problem with Safari when formSubmit()'ting. traced to this line in /usr/share/pear/data/HTML_AJAX/js/ HTML_AJAX.js: var action = form.attributes['action'].value; changed it to: var action = form.getAttribute('action'); and everything worked fine after that

Comments

 [2006-09-21 12:37 UTC] jeichorn at php dot net (Joshua Eichorn)
can someone write a quick test for this so we can get cross browser testing done. I'm pretty sure we switched away from form.getAttribute because it didn't work right in IE 6.
 [2006-09-21 13:23 UTC] alex dot chumak at gmail dot com
i have only changed it to that because you are in fact using form.getAttribute('method') a few lines below the line that gave me trouble, So instead of having 2 various ways of doing the same i switched the first to use the 2nd format. if it doesnt work right in IE, the second call would give you trouble anyway... unless there is something specific to "action" attribute and IE.
 [2006-09-21 14:22 UTC] jeichorn at php dot net (Joshua Eichorn)
If i remember correctly we changed things from getAttribute for action because it didn't work right in IE when you had a form element with the name of action or something screwy like that. We should be able to get something that works everywhere its just a matter of doing enough testing to find out what that combination of things is.
 [2006-10-25 13:11 UTC] auroraeosrose (emsmith)
The problem is accessing and setting any .value attribute in IE, it's stupid and won't let you manipulate value with setAttribute or getAttribute - maybe we need to try both like the action js unserializer does
 [2006-11-21 10:12 UTC] auroraeosrose at php dot net (Elizabeth Smith)
Should be fixed in SVN