Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.3.1

Bug #874 PEAR QA: improvement for get_class()-usage
Submitted: 2004-02-26 08:50 UTC Modified: 2004-02-26 09:19 UTC
From: pear-qa at lists dot php dot net Assigned: thesaur
Status: Closed Package: HTML_Select
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-26 08:50 UTC] pear-qa at lists dot php dot net
Description: ------------ ## from the PEAR QA team ## ## quality-assurance related ## Please note that if you don't react to this issue within 4 weeks the PEAR QA-team will take care of it automatically. This is not "rude" but necessary for QA. If this is a "false positive" and your package is not affected please apologize. This package uses get_class()-calls without care for case-sensitivity of the returned classnames. In PHP 4.x the default for getclass() was that lowercase classnames were returned. However, due to extended DOM functionality, PHP 5.x returns classnames with correct upper-and-lowercase. If you intend to run your package under both PHP4 and PHP5 please consider using case-independent comparisons or apply case-fixes. Found in: FILE: '/cvs/php/pear/HTML_Select/Select.php' : /cvs/php/pear/HTML_Select/Select.php(214): if (!is_object($result) || (get_class($result) != "db_result" && /cvs/php/pear/HTML_Select/Select.php(287): case (get_class($options) == "db_result" || is_subclass_of($options, "db_result")): Reproduce code: --------------- Affected are constructs like: if (get_class($foo) == 'foo') { ... } Possible solutions for correct class-checks: strtolower(get_class($foo)) == 'foo' is_a($foo, 'foo') !strcasecmp(get_class($foo), 'foo')

Comments

 [2004-02-26 09:19 UTC] thesaur at php dot net
Thank you for your bug report. This issue has already been fixed in the latest released version of the package, which you can download at http://pear.php.net/packages.php