Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.7

Bug #8287 Period in name is stripped?
Submitted: 2006-07-25 12:02 UTC Modified: 2008-10-27 13:30 UTC
From: chris at velocimedia dot com Assigned: till
Status: Bogus Package: Mail_Queue (version CVS)
PHP Version: 5.0.5 OS: Linux Debian
Roadmaps: (Not assigned)    
Subscription  


 [2006-07-25 12:02 UTC] chris at velocimedia dot com (Chris Go)
Description: ------------ This bug shows up on my *build* (where you can actually send mail to multiple recipients by changing the database table to receive an array). When the NAME (not the email) has a "period", for example: "Mr. Test" OR "Test Person Jr.", the email does not get sent out. If you do directly to the database to edit anything (like remove the period), you "break" the serialization and therefore the message will also die. Examples: Mr. Test <test@test.com> Test Person Jr. <testpersonjr@test.com> For now, to *not* touch the PEAR part of it, I have to parse out (using str_replace('.',' ',$name)) the "period" character on all the NAME portions before calling the Mail_Queue->put() method.

Comments

 [2006-08-09 04:08 UTC] quipo (Lorenzo Alberton)
Sorry, I don't understand... Mail_Queue doesn't strip the period in the names, they're inserted in the db as-is. At most, they're serialized if they are arrays. If you *manually* change the serialized string in the db, you are probably breaking it, but that's certainly not Mail_Queue's fault. Can you explain the issue a bit better, eventually with a reproducing script? TIA
 [2006-10-20 11:37 UTC] quipo (Lorenzo Alberton)
can I close this bug report?
 [2008-10-24 17:44 UTC] johnjreeve (John Reeve)
I have a better explanation of this bug, as it is still happening to me: We are building our outgoing emails to have the From header formatted like this: John Reeve <jreeve@pelagodesign.com> However, if we have a period in the name preceeding the email, the mail fails to get off the server, nor does it show up in /var/logs/maillog. The buggy From header looks like this: John J. Reeve <jreeve@pelagodesign.com> Here is the Header column from the database for the successful email: a:7:{s:12:"MIME-Version";s:3:"1.0";s:4:"From";s:29:"John Reeve <jreeve@pelagodesign.com>";s:8:"X-Sender";s:35:"Intervals <updates@myintervals.com>";s:6:"Sender";s:35:"Intervals <updates@myintervals.com>";s:2:"To";s:37:"John Reeve <jreeve@pelagodesign.com>";s:7:"Subject";s:60:"'Scott: reading/watching/listening to Abraham' updated - #30";s:12:"Content-Type";s:70:"multipart/alternative;\r And here is the Headers column from the failed email: a:7:{s:12:"MIME-Version";s:3:"1.0";s:4:"From";s:32:"John J. Reeve <jreeve@pelagodesign.com>";s:8:"X-Sender";s:35:"Intervals <updates@myintervals.com>";s:6:"Sender";s:35:"Intervals <updates@myintervals.com>";s:2:"To";s:37:"John Reeve <jreeve@pelagodesign.com>";s:7:"Subject";s:65:"'FAF: remove remaining items from SDC storage area' updated - #56";s:12:"Content-Type";s:70:"multipart/alternative;\r I've gone through the database and all of our failed emails have a period in the name.
 [2008-10-24 22:33 UTC] till (Till Klampaeckel)
So, it would basically need to be "John Doe Jr." <john@doe.com> and that would fix it, correct?
 [2008-10-27 13:28 UTC] johnjreeve (John Reeve)
Till, that was the problem. I've added quotation marks to the name and everything is working beautifully now. I guess we can close this "bug" out?
 [2008-10-27 13:30 UTC] till (Till Klampaeckel)
Indeed, I don't see it as a bug either. It's a usage thing. We really should not interfere there. Thanks for letting us know! :-)