Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.7.15

Request #8226 E_STRICT related to PHP5
Submitted: 2006-07-16 02:34 UTC Modified: 2008-04-07 10:18 UTC
From: tapeshag at hotmail dot com Assigned: fab
Status: Suspended Package: Cache_Lite (version 1.7.2)
PHP Version: 5.1.2 OS: Linux (Debian)
Roadmaps: 2.0    
Subscription  


 [2006-07-16 02:34 UTC] tapeshag at hotmail dot com (Tapesh Kumar Agarwal)
Description: ------------ I have error_reporting = E_ERROR|E_STRICT and using this package in php5. I get various warnings related to php5 new OOP guidelines=> "Unknown error: var: Deprecated. Please use the public/private/protected modifiers in /usr/share/php/Cache/Lite.php on line 40" Do we have plans to make it php5 compliant? Regards Tapesh Kumar Agarwal Test script: --------------- This can be reproduced with any bug

Comments

 [2006-07-16 04:33 UTC] fab at php dot net (Fabien MARTY)
=> Cache_Lite is a PHP4 package. It works with PHP5 but not with the E_STRICT error level. You have to modify your php.ini or use the following line before using Cache_Lite : error_reporting(E_ALL & ~E_STRICT); => By the way, you should upgrade to php 5.1.4 because E_STRICT changed in this version. => I plan to release a 1.8 version which will be E_STRICT compliant (with PHP >= 5.1.4)
 [2008-03-02 06:07 UTC] fab (Fabien MARTY)
close, no activity