Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.2.1

Request #7630 Listener on data submit (file upload)
Submitted: 2006-05-15 12:51 UTC Modified: 2008-11-17 08:33 UTC
From: jausions Assigned: avb
Status: Closed Package: HTTP_Request2
PHP Version: Irrelevant OS: Irrelevant
Roadmaps: (Not assigned)    
Subscription  


 [2006-05-15 12:51 UTC] jausions (Philippe Jausions)
Description: ------------ The current implementation of sendRequest() doesn't allow to check on the progress of a big file upload with the subject-observer pattern, as it is the case with the download. An integration with Event_Dispatcher would also be good. Thanks, -Philippe

Comments

 [2006-10-23 17:44 UTC] avb (Alexey Borzov)
The problem is with the current implementation of _buildRequest() method, which just creates the request as a string which is later shoved into the socket. To make this actually usable we need to refactor _buildRequest() to read chunks of files and put them into socket one by one.
 [2008-10-17 16:13 UTC] avb (Alexey Borzov)
Moving feature requests to HTTP_Request2.
 [2008-11-17 08:33 UTC] avb (Alexey Borzov)
Implemented in HTTP_Request2 0.1.0