Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.6.0

Request #7389 Codes postaux non pris en compte
Submitted: 2006-04-13 05:01 UTC Modified: 2006-04-18 12:09 UTC
From: pascal at zyzomys dot com Assigned: pajoye
Status: Closed Package: Validate_FR (version 0.5.1)
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2006-04-13 05:01 UTC] pascal at zyzomys dot com (Pascal Hubrecht)
Description: ------------ Les codes postaux suivants ne sont pas pris en compte (function region) : Principauté de Monaco : 980xx Nouvelle Calédonie : 986xx, 987xx, 988xx

Comments

 [2006-04-17 16:12 UTC] pajoye (Pierre-Alain Joye)
Do you have some specific codes which do not work? I tried with some like 98001 or 98702 and it works well.
 [2006-04-18 09:00 UTC] pascal at zyzomys dot com
echo (validate_FR::region('98')) ? "OK" : "NOK"; // should output OK but result is NOK echo (validate_FR::region('987')) ? "OK" : "NOK"; // should output OK but result is NOK
 [2006-04-18 09:02 UTC] pajoye (Pierre-Alain Joye)
Thank you for taking the time to write to us, but this is not a bug. '98' is not a valid postal code. It is the department number. '987' neither. You have to pass full postal code, like 98701 for example.
 [2006-04-18 10:46 UTC] toggg (bertrand Gugger)
Are we talking about validate_FR::region() or validate_FR::postalCode() ?
 [2006-04-18 10:48 UTC] pajoye (Pierre-Alain Joye)
Ah! right, I misread. Reopened and fix on its way :)
 [2006-04-18 12:09 UTC] pajoye (Pierre-Alain Joye)
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Validate_FR