Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.11.4

Bug #7110 Installing .phar fails
Submitted: 2006-03-13 13:41 UTC Modified: 2006-03-20 18:03 UTC
From: yunosh Assigned: cellog
Status: Closed Package: PHP_Archive (version CVS)
PHP Version: 5_1 CVS-2006-03-13 OS:
Roadmaps: (Not assigned)    
Subscription  


 [2006-03-13 13:41 UTC] yunosh (Jan Schneider)
Description: ------------ make install with PHP_5_1 CVS: Installing PEAR environment: /usr/local/lib/php/ --19:38:41-- http://pear.php.net/install-pear-nozlib.phar => `pear/install-pear-nozlib.phar' Resolving pear.php.net... 216.92.131.66 Connecting to pear.php.net|216.92.131.66|:80... connected. HTTP request sent, awaiting response... 200 OK Length: 3,166,860 (3.0M) [text/plain] 100%[====================================>] 3,166,860 143.25K/s ETA 00:00 19:39:05 (136.51 KB/s) - `pear/install-pear-nozlib.phar' saved [3166860/3166860] SECURITY ERROR: PHP_Archive::mapPhar can only be called from within the phar that initiates it

Comments

 [2006-03-14 15:53 UTC] soporte at onfocus dot cl (Cristian Rodriguez)
reproduced here too. yesterday worked fine on March 12
 [2006-03-17 23:04 UTC] cellog
this is a very odd situation - what is happening is that __FILE__ is not matching the value from get_included_files() on your system. I'll see if I can reproduce it, but I'm doubtful that I will be able to :(
 [2006-03-20 16:48 UTC] soporte at onfocus dot cl (Cristian Rodriguez)
it' still reproducible, with today's CVS. both x86 and x86_64. just tried it,
 [2006-03-20 18:03 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. this is a bug in PHP_Archive, and is now fixed in both PHP_Archive cvs and in the install-pear-nozlib.phar Also, for the root cause of this bug, see: http://bugs.php.net/?id=36809