Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 2.4.5

Bug #707 "deadline"-parameter doesn't work
Submitted: 2004-02-08 04:33 UTC Modified: 2004-02-08 17:48 UTC
From: metz Assigned: jan
Status: Closed Package: Net_Ping
PHP Version: Irrelevant OS: Debian Linux
Roadmaps: (Not assigned)    
Subscription  


 [2004-02-08 04:33 UTC] metz
Description: ------------ When you specify a "deadline" for your Ping-request this works fine under e.g. Fedora Linux. The "deadline"-parameter is resolved to command-line parameter "-w". However, Debian uses "-i" at the commandline. Reproduce code: --------------- Use the normal Net_Ping-example that's shipped with the class. For the arguments use: $ping->setArgs(array('count' => 2, 'deadline' => 1)); Expected result: ---------------- Should work for all Linux-versions. Actual result: -------------- Works for most Linux-versions (whyever Debian is different ...) :-((

Comments

 [2004-02-08 06:11 UTC] jan
Hi, the deadline option does not exist in debian's ping. THe -i option does something different: i interval Wait interval seconds between sending each packet. The default is to wait for one second between each packet normally, or not to wait in flood mode. Only super-user may set interval to values less 0.2 seconds. and -w deadline Specify a timeout, in seconds, before ping exits regardless of how many packets have been sent or received. In this case ping does not stop after count packet are sent, it waits either for deadline expire or until count probes are answered or for some error notification from network. What would you prefer to happen on debian now? silently ignore the option, yield a warning? I am open for suggestions. Jan --
 [2004-02-08 06:29 UTC] metz
I'd prefer ignoring it. Please document this behaviour somewhere. Since a script should run on any host system, giving a warning (and maybe even not executing the ping) is no clean solution in my eyes.
 [2004-02-08 17:48 UTC] jan
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.