Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.5.5

Request #6676 just a note about source code comments
Submitted: 2006-02-02 17:14 UTC Modified: 2007-12-12 14:43 UTC
From: msaraujo Assigned: davidc
Status: Closed Package: Validate_US
PHP Version: Irrelevant OS: Linux
Roadmaps: 0.5.3    
Subscription  


 [2006-02-02 17:14 UTC] msaraujo
Description: ------------ Examples: print Validate_US::phoneNumber("2374434",false); // 1 print Validate_US::phoneNumber("234 4434",false); // 1 print Validate_US::phoneNumber("234-4434",false); // 1 Test script: --------------- if (!$requireAreaCode) { // just seven digits, maybe a space or dash if (preg_match('/^[2-9]\d{2}[- ]?\d{4}$/', $number)) { return true; } } It is not a bug, but it is not well defined. // just seven digits, maybe a space or dash or nothing 2374434 This one is not explained on the source 234 4434 234-4434

Comments

 [2006-02-02 17:26 UTC] davidc
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.