Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.7.3

Bug #6600 Versions >= 0.6.0 fail in PHP < 4.3.3
Submitted: 2006-01-26 15:42 UTC Modified: 2006-12-24 14:25 UTC
From: bburton at mail dot com Assigned: blindman
Status: Closed Package: Text_Highlighter
PHP Version: 4.3.2 OS: RedHat ES 3.0
Roadmaps: (Not assigned)    
Subscription  


 [2006-01-26 15:42 UTC] bburton at mail dot com
Description: ------------ When attempting to use the latest currently available version of Text_Highlighter (0.6.6), it returns an error on line 252 relating to a mismatched number of parameters for preg_match. It turns out that in PHP 4.3.3, an additional parameter for the starting position was added to preg_match. This additional parameter was then utilized in Text_Highlighter starting with version 0.6.0. However, I couldn't find anything in the changelog or documentation that mentioned PHP 4.3.3 being a requirement. Expected result: ---------------- The installer for PEAR should be fixed to require PHP 4.3.3 or later as appropriate. After checking earlier versions of Text_Highlighter, I found version 0.5.1 is the latest that will work on PHP 4.3.2.

Comments

 [2006-02-03 18:33 UTC] blindman at php dot net
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Text_Highlighter