Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.5.0a1

Bug #6306 Tokenizer doesn't read "....<%{$key}>..." properly
Submitted: 2005-12-20 14:08 UTC Modified: 2006-04-26 23:38 UTC
From: derick Assigned: cellog
Status: Closed Package: PhpDocumentor
PHP Version: 5.1.1 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-12-20 14:08 UTC] derick
Description: ------------ ANother one is that the tokenizer handles the following wrong: # throw new ezcTranslationException( "The parameter <%{$key}> does not exist.", ezcTranslationException::PARAMETER_MISSING ); For some reason it chokes on the {$key} part. Everything generated after this is light blue (with the phpedit) theme. Test script: --------------- <?php throw new ezcTranslationException( "The parameter <%{$key}> does not exist.", ezcTranslationException::PARAMETER_MISSING ); ?>

Comments

 [2006-04-26 23:38 UTC] cellog (Greg Beaver)
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. this was caused by 2 problems. One in the options.ini for phpedit, the other in the HighlightParser.