Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.7.0

Bug #6028 incompatability with php5
Submitted: 2005-11-21 17:48 UTC Modified: 2006-04-25 00:41 UTC
From: tomas dot varaneckas at gmail dot com Assigned: farell
Status: Closed Package: PEAR_PackageFileManager
PHP Version: 5.0.5 OS: Linux Debian
Roadmaps: (Not assigned)    
Subscription  


 [2005-11-21 17:48 UTC] tomas dot varaneckas at gmail dot com
Description: ------------ // $Id: File.php,v 1.21 2005/03/28 06:37:35 cellog Exp $ File.php line 108: $ext = array_pop(explode('.', $file)); as php5 requires reference as input for array_pop, function output cannot be assigned. Quick fix: $ext = array_pop($array = explode('.', $file));

Comments

 [2006-01-09 12:05 UTC] farell
Hello Tomas, Version you are testing is probably PFM 1.5.0/1.5.1 or /1.5.2 This bug was fixed by Greg on File.php,v 1.23 on release 1.6.0 alpha series. Even if Greg applied a path, i've tested myself $ext = array_pop(explode('.', $file)); on PHP 5.1.1 Windows XP without any problem. It seems latest version of PHP 5 is better than 5.0.5 I suggest an upgrade to PHP 5.1.1 (recommended). Could you re-test it under your OS with PHP 5.1.1 and tell us the result , please ! Laurent
 [2006-04-25 00:41 UTC] farell (Laurent Laville)
No reply to feedback after 106 days. I close this bug definitively. Laurent