Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.5

Bug #579 Net_Whois fails
Submitted: 2004-01-14 15:42 UTC Modified: 2004-08-04 11:20 UTC
From: amt Assigned: svenasse
Status: Closed Package: Net_Whois
PHP Version: Irrelevant OS: Mac OS X
Roadmaps: (Not assigned)    
Subscription  


 [2004-01-14 15:42 UTC] amt
Description: ------------ Net_Whois fails to work on Mac OS X because on line 224 it calls getservbyname('whois', 'tcp'), but /etc/services on Mac OS X only has entries for whois++ and rwhois. Reproduce code: --------------- Standard usage: require 'Net/Whois.php'; $server = 'whois.networksolutions.com'; $query = 'example.org'; $whois = new Net_Whois; $data = $whois->query($query, $server); print $data; Expected result: ---------------- Lots of information on example.org. Actual result: -------------- PHP Warning: fsockopen(): unable to connect to 129.33.96.137:0 (Failed to parse address "129.33.96.137") in /usr/lib/php/Net/ Socket.php on line 108 PHP Notice: Object of class PEAR_Error could not be converted to string in /usr/lib/php/Net/Whois.php on line 238 PHP Notice: Object of class PEAR_Error could not be converted to string in /Users/adam/Documents/php/php5/whois.php on line 9

Comments

 [2004-07-11 17:42 UTC] gurugeek
Dear Maintainer, Your package net_whois has currently 3 open bugs. We urge you to take the necessary steps to solve the reported issues at your soonest convenience. If the bug issue hasn’t been addressed yet you are kindly asked to take the necessary steps to ensure a prompt resolution of the problem. If you already addressed the reported problem feel free to change the bug status as soon as possible. Regards David Costa PEAR Quality Assurance pear-qa@lists.php.net
 [2004-08-04 11:20 UTC] svenasse
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. Most service files, be it on RedHat/FreeBSD/Mac OS X, have "nicname" as the service name and "whois" as the alias. OS X has "nicname" as a valid service name for port 43. I have looked up the port assignments at IANA (http://www.iana.org/assignments/port-numbers) and they only have "nicname" as the service name.
 [2005-01-27 15:08 UTC] cmv
It's over a year since the original bug report, and close to 2 years since the last release of this package. This issue still isn't resolved in my books. If the code has changed in CVS, then please release a new version of the package.
 [2007-02-23 21:11 UTC] hostmaster at shupp dot org (Bill Shupp)
This bug just got me as well. If it's fixed in CVS, why not release an update and save other folks the time?
 [2008-03-05 23:00 UTC] surfchen (Surf Chen)
I think we should always use CVS version in the PEAR world. We don't need release.