Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.9.3

Bug #578 setVPageBreaks doesn't handle multiple value arrays
Submitted: 2004-01-14 15:21 UTC Modified: 2004-04-05 19:45 UTC
From: natel at tocquigny dot com Assigned: xnoguer
Status: Closed Package: Spreadsheet_Excel_Writer
PHP Version: 4.3.4 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2004-01-14 15:21 UTC] natel at tocquigny dot com
Description: ------------ The worksheet function setVPageBreaks() does not insert more than one page break when a multiple value array is passed through. Regardless of the order of the values in the array, the lowest valued column is the only page break inserted. Note: When I use $workbook->setVersion(8), the function works as intended!! Reproduce code: --------------- $worksheet->setVPageBreaks(array(15, 24, 33, 42, 51)); Expected result: ---------------- I expect a vertical page break to be inserted into the Excel file before the 15th, 24th, 33rd, 42nd, and 51st columns. Actual result: -------------- Only one page break is inserted, before the 15th column.

Comments

 [2004-01-14 16:12 UTC] natel at tocquigny dot com
Changed the OS from Windows to Linux
 [2004-04-05 19:45 UTC] xnoguer at php dot net
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.