Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #5545 package not installable
Submitted: 2005-09-28 07:29 UTC Modified: 2005-10-14 11:52 UTC
From: glen at delfi dot ee Assigned: arnaud
Status: Closed Package: Image_Remote
PHP Version: 5.0.5 OS: PLD Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-09-28 07:29 UTC] glen at delfi dot ee
Description: ------------ $ pear install --installroot=/tmp/pear --nodeps Image_Remote-beta File http://pear.php.net:80/rest/r/image_remote/1.0.xml not valid (received: HTTP/1.1 404 Not Found ) Cannot initialize 'Image_Remote-beta', invalid or missing package file Package "Image_Remote-beta" is not valid install failed builder@haarber-amd64 pear/RPMS $ pear -V PEAR Version: 1.4.1 PHP Version: 5.0.5 Zend Engine Version: 2.0.5 Running on: Linux [cut] 2.6.12.5-0.2 #1 Thu Aug 18 23:21:08 EEST 2005 x86_64 also with older, 1.3 series PEAR: # pear install --installroot=/tmp/pear --nodeps Image_Remote-beta downloading Image_Remote-1.0.tgz ... Starting to download Image_Remote-1.0.tgz (4,764 bytes) .....done: 4,764 bytes Unable to open /tmp/pearWbCXVo/package.xml # pear -V PEAR Version: 1.3.5 PHP Version: 4.4.0 Zend Engine Version: 1.3.0 Running on: Linux [cut] 2.4.22-1.2115.nptlsmp #1 SMP Wed Oct 29 15:30:09 EST 2003 i686

Comments

 [2005-10-03 15:54 UTC] glen at delfi dot ee
it seems that package.xml is in wrong place in the tarball. recreating tarball having package.xml in toplevel, the error is gone.
 [2005-10-14 11:52 UTC] arnaud
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. Release 1.0.1 fixes the issue.