Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.3

Bug #520 Fatal error: Call to undefined method mdb_error::tableinfo() in /usr/local/lib/
Submitted: 2004-01-05 06:46 UTC Modified: 2006-02-07 02:34 UTC
From: mirko dot c at terasonline dot com Assigned: quipo
Status: Bogus Package: MDB_QueryTool
PHP Version: 5.0.0b2 (beta2) OS: fedora
Roadmaps: (Not assigned)    
Subscription  


 [2004-01-05 06:46 UTC] mirko dot c at terasonline dot com
Description: ------------ Fatal error: Call to undefined method mdb_error::tableinfo() in /usr/local/lib/php/MDB/QueryTool/Query.php on line 1295 Reproduce code: --------------- Fatal error: Call to undefined method mdb_error::tableinfo() in /usr/local/lib/php/MDB/QueryTool/Query.php on line 1295 Expected result: ---------------- getAll(); Actual result: -------------- Fatal error: Call to undefined method mdb_error::tableinfo() in /usr/local/lib/php/MDB/QueryTool/Query.php on line 1295

Comments

 [2004-01-05 07:35 UTC] quipo
which MDB and MDB_QueryTool version are you using? Latest stable releases (@2004-01-05) are MDB 1.1.4RC6 and MDB_QueryTool 0.9.6. Please check them or CVS version, if the problem persists then provide me with some more info, since I can't reproduce the error.
 [2004-01-05 08:46 UTC] quipo
Sorry, but your problem does not imply a bug in PEAR itself. For a list of more appropriate places to ask for help using PEAR, please visit http://pear.php.net/support.php as this bug system is not the appropriate forum for asking support questions. Thank you for your interest in PEAR. this is not a MDB_QT bug, but a user mistake :)
 [2006-02-06 17:49 UTC] tbarsness at barsnesssolutions dot com
This error isn't bogus. It happened to me on php5.1.2 with apache 2.0.55. I figured out that mine was because of a problem with privileges, but I feel MDB should fail more gracefully than "call to undefined method"
 [2006-02-07 02:34 UTC] quipo
can you provide a reproducing script?