Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.2.2b2

Bug #4977 Net_IPv6::compress() breaks on already-compressed addresses
Submitted: 2005-08-02 21:50 UTC Modified: 2006-12-24 14:51 UTC
From: pvenegas at gmail dot com Assigned: alexmerz
Status: Closed Package: Net_IPv6
PHP Version: 5.0.4 OS: FreeBSD 5.3-RELEASE #0
Roadmaps: (Not assigned)    
Subscription  


 [2005-08-02 21:50 UTC] pvenegas at gmail dot com
Description: ------------ Error when running Net_IPv6::compress() on an already compressed IPv6 address string. Test script: --------------- <?php include "/usr/local/lib/php/pear/Net/IPv6.php"; echo Net_IPv6::compress("2001:ec8:1:1:1:1:1:1") . "\n"; ?> Expected result: ---------------- 2001:ec8:1:1:1:1:1:1 Actual result: -------------- 2:01:ec8:1:1:1:1:1:1

Comments

 [2005-08-03 08:00 UTC] alexmerz
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Net_IPv6 This was caused by not checking if in the url is at least one possibility to compress something. Fixed in 1.0.4. BTW: the given example address isn't compressed and can't be compressed