Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #4867 enumOptions renumbered for NULL fields
Submitted: 2005-07-19 23:17 UTC Modified: 2006-12-16 02:17 UTC
From: evt at infoware dot com dot au Assigned: justinpatrin
Status: Closed Package: DB_DataObject_FormBuilder
PHP Version: 5.0.3 OS: Suse
Roadmaps: (Not assigned)    
Subscription  


 [2005-07-19 23:17 UTC] evt at infoware dot com dot au
Description: ------------ If I define my options in the enumOptions array with specific key values that I wish to store in the DB, if the DB field allows NULL then formbuilder will add the empty option and renumber my option values. This is because array_merge is used, maybe it would be better to use the + operator to merge the arrays, that way the option numbers will be preserved. formbuilder.php version: * @version $Id: FormBuilder.php,v 1.189 2005/06/17 16:32:41 justinpatrin Exp $ Reproduce code: --------------- ... if (in_array($key, $this->selectAddEmpty) || !($type & DB_DATAOBJECT_NOTNULL)) { $options = array_merge(array('' => $this->selectAddEmptyLabel), $options); } ...

Comments

 [2005-07-20 01:32 UTC] justinpatrin
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.
 [2005-07-21 01:42 UTC] evt at infoware dot com dot au
Works perfectly, thanks.
 [2005-07-21 01:42 UTC] evt at infoware dot com dot au
Works perfectly, thanks.