Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.9.5

Bug #4718 Can't upgrade to Mail 1.1.5
Submitted: 2005-06-30 10:55 UTC Modified: 2005-07-20 17:20 UTC
From: snowkrash at xs4all dot nl Assigned:
Status: Duplicate Package: PEAR
PHP Version: 5.0.3 OS: Win XP SP1 NL
Roadmaps: (Not assigned)    
Subscription  


 [2005-06-30 10:55 UTC] snowkrash at xs4all dot nl
Description: ------------ PEAR REMOTE-LIST says Mail 1.1.5 is available on the pear.php.net channel. On my system 1.1.4 is installed. So I'd like to upgrade. But doing PEAR UPGRADE-ALL or PEAR UPGRADE MAIL keeps telling me that Mail 1.1.4 is already installed??? Of course --force isn't an option. The only effect is that Mail 1.1.4 is overwritten by the same version. Reproduce code: --------------- C:\Program Files\php\PEAR> (...) Image_XBM 0.2.0 Inline_C 0.1 LiveUser 0.16.0 LiveUser_Admin 0.3.0 Log 1.8.7 Mail 1.1.5 <------- ! Mail_IMAP 1.1.0RC2 Mail_IMAPv2 0.2.0 Mail_Mbox 0.3.0 (...) C:\Program Files\php\PEAR>pear upgrade mail Skipping package "pear/Mail", already installed as version 1.1.4 No valid packages found upgrade failed C:\Program Files\php\PEAR>pear upgrade -f -a mail downloading Mail-1.1.4.tgz ... Starting to download Mail-1.1.4.tgz (14,548 bytes) .....done: 14,548 bytes upgrade ok: channel://pear.php.net/Mail-1.1.4 C:\Program Files\php\PEAR> Expected result: ---------------- Well, 1.1.5 running on my system.

Comments

 [2005-07-20 17:20 UTC] cellog
this is a duplicate of #4741, and is fixed. run pear clear-cache to fix temporarily