Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.0.2

Bug #4617 NOT NULL Enum fields are not required anymore
Submitted: 2005-06-17 06:23 UTC Modified: 2006-12-16 02:19 UTC
From: pma at simple dot ch Assigned: justinpatrin
Status: Closed Package: DB_DataObject_FormBuilder
PHP Version: 4.3.4 OS: Debian Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-06-17 06:23 UTC] pma at simple dot ch
Description: ------------ After upgrading from version 0.16.0 to version 0.17.1 I noticed that fields that were required in the older version are not required any more. These fields are all of type ENUM and set to "NOT NULL". The comboboxes were also not filled with the default value set in the table.

Comments

 [2005-06-17 11:40 UTC] justinpatrin
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/DB_DataObject_FormBuilder This is an issue I fixed a little while ago in CVS but hadn't released. Thanks for reminding me. Please try version 0.17.2.