Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.7.0

Bug #4604 validatePackageInfo implementation error
Submitted: 2005-06-16 06:28 UTC Modified: 2005-07-24 10:58 UTC
From: farell Assigned: cellog
Status: Closed Package: PEAR_PackageFileManager
PHP Version: 4.3.11 OS: Windows XP
Roadmaps: (Not assigned)    
Subscription  


 [2005-06-16 06:28 UTC] farell
Description: ------------ Today, my goal was to prepare a package only for HTML_Progress2 examples. Using PFM 1.5.2 or even 1.6.0a1 i got the same problems. (( I'm still using PEAR 1.3.5 )) Even with other packages, i got a warning which was strange only i've found why. On PFM 1.5.2 // $Id: PackageFileManager.php,v 1.42 2005/04/06 22:21:20 cellog Exp $ at line 971, you wrote : $common->validatePackageInfo($packagexml, $warnings, $errors, but first argument is not expected the xml file content, but either - the xml filename , or - an xml array structure If you've not such condition, you'll get a warning at line 845 of PEAR_Common file Id: Common.php,v 1.126.2.2 2004/12/27 07:04:19 cellog So to fix, this: you should write $common->validatePackageInfo($this->_packageXml, $errors, $warnings, Oh yes, take care that you've swapped arg2 and arg3 too !!! Now like that, all run pretty fine only if option simpleoutput is set to false (default). Otherwise the filelist gave an error due to structure of simpleDirTag. And there it's a bit more complex to fix. So sorry, i'll let you find the best solution. Hope these informations will help ! Laurent

Comments

 [2005-07-24 10:58 UTC] cellog
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. There was a bug in PEAR_Common::validatePackageInfo() in all versions of PEAR 1.4.0a* to date, it will be fixed in a13, and so I'll make a note in 1.6.0a2's package.xml