Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.13.1

Bug #4420 GetReturnURL.php / SetReturnURL.php
Submitted: 2005-05-24 13:36 UTC Modified: 2006-12-27 00:20 UTC
From: talyaniv at gmail dot com Assigned: amt
Status: Closed Package: Services_Ebay
PHP Version: 5.0.2 OS: Linux
Roadmaps: (Not assigned)    
Subscription  


 [2005-05-24 13:36 UTC] talyaniv at gmail dot com
Description: ------------ There is a problem with the spelling (upper / lower case) of the file names: Ebay/Call/GetReturnURL.php and Ebay/Call/SetReturnURL.php The correct names should be: GetReturnUrl.php and SetReturnUrl.php (note: URL vs. Url) The bug is not catched in Windows, as Windows is case insensitive, but it is catced in Unix/Linux. I simply changed the names of the files and the problem was resolved. Reproduce code: --------------- In Linux - open examples/example_GetRuName.php, change the suggested 'MyUseCase' to a proper EBay user and run the script. You will see the errors. Expected result: ---------------- No errors Actual result: -------------- A list of thrown errors

Comments

 [2005-05-24 13:47 UTC] amt
These function names match the ones in the eBay API, where the spelling is URL in all capital letters. Or am I missing something?
 [2005-05-24 14:35 UTC] talyaniv at gmail dot com
The problem was reproduced as proposed here, using examples/example_GetRuName.php. When debugging I found that in Ebay.php, line 395: if (file_exists($filename))... The given $filename was "SetReturnUrl.php", while the filename in the system was in capitals, hence the problem. The problem was fixed after I changed the file name itself.
 [2005-05-24 14:53 UTC] amt
Now I understand. The example is incorrect. The calls and filenames are correct. I have fixed the example to use uppercase letters.