Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.6.0a3

Request #4372 addition of glob() function for php < 4.3.0
Submitted: 2005-05-17 19:58 UTC Modified: 2006-01-02 07:41 UTC
From: judas at mailchile dot com Assigned: arpad
Status: Closed Package: PHP_Compat
PHP Version: 4.2.2 OS: Irrelevant
Roadmaps: 1.6.0a1    
Subscription  


 [2005-05-17 19:58 UTC] judas at mailchile dot com
Description: ------------ I ask the adittion of glob() function,for people using PHP < 4.3.0 Reproduce code: --------------- none Expected result: ---------------- PHP_Compat will provide glob() Actual result: -------------- Actually function is not implemented

Comments

 [2005-11-22 05:07 UTC] aidan
After spending a number of hours trying to write my own implementation, and another couple of hours sorting through the various other implementations on the net, I've decided it's simply not practical to rewrite the entire glob library in php. I'm more than happy, even delighted, for someone to prove me wrong.
 [2006-01-02 07:19 UTC] arpad
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better.
 [2006-01-02 07:41 UTC] arpad
To clarify the rather confusing quick-reply, I've replicated this function to work with PHP 3.0.9+. It will be in the next release, but for now you can get it from: http://cvs.php.net/viewcvs.cgi/*checkout*/pear/PHP_Compat/Compat/Function/glob.php