Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.13.1

Bug #4296 Sandbox XML encoding is UTF-8
Submitted: 2005-05-06 09:45 UTC Modified: 2006-12-17 05:02 UTC
From: smithies at wharton dot upenn dot edu Assigned: schst
Status: Closed Package: Services_Ebay
PHP Version: 5.0.4 OS: Mac OS 10.4
Roadmaps: (Not assigned)    
Subscription  


 [2005-05-06 09:45 UTC] smithies at wharton dot upenn dot edu
Description: ------------ In Session.php of version 0.11 it has the option to specify encoding type for the sandbox environment. For sandbox this is set to ISO-8859-1 with a note that the sandbox doesn't support UTF-8 "yet!" It would appear that the sandbox ow supports UTF-8 and no longer supports ISO seeing as whenever this is set to ISO I get the following error in my logs and the service crashes: PHP Fatal error: Uncaught <table border="1" cellspacing="0">\n<tr><td colspan="3" bgcolor="#aaaaaa" align="center"><b>Exception trace</b></td></tr>\n<tr><td align="center" bgcolor="#cccccc" width="20"><b>#</b></td><td align="center" bgcolor="#cccccc"><b>Function</b></td><td align="center" bgcolor="#cccccc"><b>Location</b></td></tr> \n<tr><td align="center">0</ td><td>Services_Ebay_Session::sendRequest()</td><td>/usr/ local/php5/lib/php/Services/Ebay/Session.php:465</td></tr> \n<tr><td align="center">1</td><td>Services_Ebay_Session- >sendRequest('GetItem', Array, 1, true)</td><td>/usr/local/ php5/lib/php/Services/Ebay/Call.php:114</td></tr>\n<tr><td align="center">2</td><td>Services_Ebay_Call_GetItem->call (Object(Services_Ebay_Session))</td><td>/usr/local/php5/lib/ php/Services/Ebay/Call/GetItem.php:38</td></tr>\n<tr><td align="center">3</td><td>Services_Ebay_Call_GetItem->call (Object(Services_Ebay_Session))</td><td>/usr/local/php5/lib/ php/Services/Ebay.php:370</td></tr>\n<tr><td align="center">4</td><td>Services_Ebay->__call('GetItem', Arr in /usr/local/php5/lib/php/Services/Ebay/Session.php on line 465 Reproduce code: --------------- Try running any call to the sandbox with the encoding set to ISO-8859-1

Comments

 [2005-05-06 10:46 UTC] smithies at wharton dot upenn dot edu
If you change the encoding to UTF-8 it takes care of this issue
 [2005-06-05 08:30 UTC] schst
Thank you for your bug report. This issue has been fixed in the latest released version of the package, which you can download at http://pear.php.net/get/Services_Ebay