Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.4.0

Bug #4150 Error in Admin::getGroups
Submitted: 2005-04-14 18:10 UTC Modified: 2006-12-24 16:14 UTC
From: jan at ivtaco dot se Assigned: lsmith
Status: Closed Package: LiveUser_Admin
PHP Version: 5.0.2 OS: Windows XP
Roadmaps: (Not assigned)    
Subscription  


 [2005-04-14 18:10 UTC] jan at ivtaco dot se
Description: ------------ in the version av LiveUser_Admin 0.15.1 the function getGroups does not return the intended result. It: 1. Does only return the first level of subgroups (when an filter group_id is added. 2. Does return all groups without internal hierarchy if filter is removed (i.e. an empty array is used) Reproduce code: --------------- $groups = $admin->perm->getGroups( array( 'select' => 'all', 'rekey' => true, 'filters' => array(), 'subgroups' => 'hierachy', ) ); Expected result: ---------------- Get all groups, with subgroups listed in hierarchy. Actual result: -------------- Returns all groups as if they were all Level 0 groups.

Comments

 [2005-04-17 13:41 UTC] smith at backendmedia dot com
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better. - typo fix: hierachy -> hierarchy (bug #4150)