Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 1.4.0a3

Bug #4102 Problem detecting os method ls()
Submitted: 2005-04-08 06:08 UTC Modified: 2006-02-09 18:12 UTC
From: cluetjen Assigned: toby
Status: Closed Package: Net_FTP
PHP Version: 4.3.9 OS: Debian Linux testing
Roadmaps: (Not assigned)    
Subscription  


 [2005-04-08 06:08 UTC] cluetjen
Description: ------------ Net_FTP->ls() Function has problems with the following output I've got from an FTP Server with NET_FTP_RAWLIST dr-xr-x--- 9 web10 www-data 4096 May 17 2004 . dr-xr-x--- 9 web10 www-data 4096 May 17 2004 .. drwx------ 2 root root 4096 May 17 2004 .configs drwxrwxrwx 15 web10 ftponly 4096 Apr 1 17:33 html drwxr-xr-x 3 root root 4096 Apr 5 00:00 log drwxrwxrwx 2 web10 ftponly 4096 Apr 5 16:20 phptmp drwxr-xr-x 2 web10 ftponly 4096 May 17 2004 restore ls() function detects this as windows server, possibly there's a problem with the time / year? (Please don't ask why the server returns this - I don't know... ;-) Reproduce code: --------------- $res = $fpt->ls('/', NET_FTP_DIRS_ONLY); Actual result: -------------- [6] => Array ( [name] => 17:33 html [date] => drwxrwxrwx 15 web10 ftponly 4096 [is_dir] => 1 [stamp] => -1 ) [7] => Array ( [name] => backup [date] => drwxr-xr-x 2 root root 4096 May [is_dir] => 2004 [stamp] => -1 )

Comments

 [2005-04-08 07:34 UTC] toby
I'll fix that bug as soon as I got my net connection back (by monday, if everything is ok) and release 1.3.2.
 [2006-02-09 18:12 UTC] toby
This bug has been fixed in CVS. If this was a documentation problem, the fix will appear on pear.php.net by the end of next Sunday (CET). If this was a problem with the pear.php.net website, the change should be live shortly. Otherwise, the fix will appear in the package's next release. Thank you for the report and for helping us make PEAR better. AFAIK it was the "-" in your group name. Should be fixed.