Package home | Report new bug | New search | Development Roadmap Status: Open | Feedback | All | Closed Since Version 0.13.0

Bug #4074 problem with the wdsl creation
Submitted: 2005-04-06 03:31 UTC Modified: 2006-12-17 11:22 UTC
From: phil_soap at smurfy dot de Assigned: chagenbu
Status: Closed Package: SOAP
PHP Version: Irrelevant OS:
Roadmaps: (Not assigned)    
Subscription  


 [2005-04-06 03:31 UTC] phil_soap at smurfy dot de
Description: ------------ There is a small Problem with the WDSL creation. while parsing the wdsl file it checks all functions arguments for complex types. if a arg is a complex type it adds a comment. (varname is $comment). the problem is if you have a function like this: function foo($bar,$foobar) and $bar is a complex type and $foobar is a boolean. it creates no comment fpr the complex type $bar, because the "new" comment for $foobar is empty and the var $comment will be overwritten. it creates only for the lastest argument given a comment. so here is the fix: 510c510 < $comments_final = ''; --- > $comments = ''; 552d551 < $comments_final .= $comments; 568c567 < $class .= " function &$opname($args) {\n$comments_final$wrappers". --- > $class .= " function &$opname($args) {\n$comments$wrappers". it adds a new variable called $comments_final, to this variable i add the $comments created for each argument and finally adds the $comments_final. hope that helps smurfy

Comments

 [2005-04-08 22:19 UTC] chagenbu
This bug has been fixed in CVS. In case this was a documentation problem, the fix will show up at the end of next Sunday (CET) on pear.php.net. In case this was a pear.php.net website problem, the change will show up on the website in short time. Thank you for the report, and for helping us make PEAR better.